Jump to content

Check us out:

Photo

ET and OS X


Best Answer djbo , 30 July 2012 - 08:36 PM

This is what I used which is actually what Pey already posted.

Source is this http://forums.warche...OSX-2-60d/page4

I'll post it here but keep reading cause this on itself doesn't work or at least it didn't with me.


1. Download (Wolfenstein Enemy Territory 2.60d)
2. Drag the Wolfenstein ET folder to your Applications folder.
3. Run the punkbuster installer.
4. In ~/Library/Application Support/ create "Wolfenstein ET" folder and therein "etmain" folder.
5. Download a punkbuster etkey
6. Put the etkey in the following location: ~/Library/Application Support/Wolfenstein ET/etmain
7. In ~/Library/Application Support/Wolfenstein ET/etmain/ create a file: "autoexec.cfg"
8. Paste the two lines of this file:

seta r_colorbits "32"
set r_allowExtensions 0


9. Run ET.

10. Set screen resolution via the following commands in the game console (press ~ after launching the game to view game console):

/r_customwidth XXXX
/r_customheight XXXX


/r_mode -1


Remember line 4 is a hidden directory so either make it visible or else use finder. In the top navigation bar go to "go", pull down the menu and go to "go to" then type (or past from here) "~/Library" then go to the folder "Application Support" and create a folder Wolfenstein ET and in that one a subfolder etmain. Then continue with line 5.

For some reason after creating autoexec.cfg the game started but made a humming sound and that was it. So I downloaded this autoexec found here "https://sites.google...fanpiot/prefabs" (scroll down to mac configs) copy that file into your "~/Library/Application Support/Wolfenstein ET/etmain" and voila the game runs. Close the game and open your auto exec again and add "set r_allowExtensions 0" if the game lags (it did with me, added it and have a smooth 90fps on a crappy intel graphics.

Now if you run a macbook pro with dual graph card (intel-nvidia) you'll need to run a proggy called gfxcardstatus which you can find here http://www.macupdate.../gfxcardstatus.

Should work. The only problem I'm aware off is on a 2010 macbook with ATI that don't support OpenGL tho I think there is a solution for that to now I think. Other than that It runs smooth.

I've personally tested this on my macbook air on both Lion and now on Mountain Lion.

Good luck had have fun with ET :)

Djeebs Go to the full post


  • Please log in to reply
11 replies to this topic

#1
Aco

Aco

    Becoming a Part of the Forum

  • Bunker Members
  • 277 posts
  • Gender:Male
  • Location:Stuttgart, Germany
  • Server:Bunker #1
Click to view battle stats
Hi Guys,

does anyone run ET under OS X?
I Have OS X Lion (10.7) installed and I don't know if ET will run again maybe under Mountain Lion...
Does anyone know?

#2
-=BRASIL=-

-=BRASIL=-
  • Gender:Male
  • Location:Brasil (Rio de Janeiro) Copacabana Beach
  • Server:Unselected
Click to view battle stats
DJBo?
Problems on your ET?

;)

#3
djbo

djbo
  • Gender:Male
  • Location:Belgium
  • Server:Bunker #2
Click to view battle stats
It run with lion as well as on mountain lion. Test both and both work :) lying in bath after a long day work in the garden, will see if I can upload a link but Pey pretty much described it all in that other topic ( forgot wich :) )

#4
djbo

djbo
  • Gender:Male
  • Location:Belgium
  • Server:Bunker #2
Click to view battle stats
This is what I used which is actually what Pey already posted.

Source is this http://forums.warche...OSX-2-60d/page4

I'll post it here but keep reading cause this on itself doesn't work or at least it didn't with me.


1. Download (Wolfenstein Enemy Territory 2.60d)
2. Drag the Wolfenstein ET folder to your Applications folder.
3. Run the punkbuster installer.
4. In ~/Library/Application Support/ create "Wolfenstein ET" folder and therein "etmain" folder.
5. Download a punkbuster etkey
6. Put the etkey in the following location: ~/Library/Application Support/Wolfenstein ET/etmain
7. In ~/Library/Application Support/Wolfenstein ET/etmain/ create a file: "autoexec.cfg"
8. Paste the two lines of this file:

seta r_colorbits "32"
set r_allowExtensions 0


9. Run ET.

10. Set screen resolution via the following commands in the game console (press ~ after launching the game to view game console):

/r_customwidth XXXX
/r_customheight XXXX


/r_mode -1


Remember line 4 is a hidden directory so either make it visible or else use finder. In the top navigation bar go to "go", pull down the menu and go to "go to" then type (or past from here) "~/Library" then go to the folder "Application Support" and create a folder Wolfenstein ET and in that one a subfolder etmain. Then continue with line 5.

For some reason after creating autoexec.cfg the game started but made a humming sound and that was it. So I downloaded this autoexec found here "https://sites.google...fanpiot/prefabs" (scroll down to mac configs) copy that file into your "~/Library/Application Support/Wolfenstein ET/etmain" and voila the game runs. Close the game and open your auto exec again and add "set r_allowExtensions 0" if the game lags (it did with me, added it and have a smooth 90fps on a crappy intel graphics.

Now if you run a macbook pro with dual graph card (intel-nvidia) you'll need to run a proggy called gfxcardstatus which you can find here http://www.macupdate.../gfxcardstatus.

Should work. The only problem I'm aware off is on a 2010 macbook with ATI that don't support OpenGL tho I think there is a solution for that to now I think. Other than that It runs smooth.

I've personally tested this on my macbook air on both Lion and now on Mountain Lion.

Good luck had have fun with ET :)

Djeebs

#5
-=BRASIL=-

-=BRASIL=-
  • Gender:Male
  • Location:Brasil (Rio de Janeiro) Copacabana Beach
  • Server:Unselected
Click to view battle stats
ACE, when u you tested, please give HERE a feedback ok?
Thanks DJBo :D

#6
CrazyT

CrazyT

    Hi, My Name Is..

  • Bunker Members
  • 17 posts
  • Gender:Male
  • Location:Netherlands
  • Server:Unselected
Click to view battle stats

Hi,

 

I also want to download et on my mbp, but i get always the same error when i want to start the game.

 

Process:         Wolfenstein ET [823]
Path:            /Applications/Wolfenstein ET/Wolfenstein ET.app/Contents/MacOS/Wolfenstein ET
Identifier:      com.activision.rtcw_et
Version:         2.60b4 (2.60b4)
Code Type:       X86 (Native)
Parent Process:  launchd [290]
Responsible:     Wolfenstein ET [823]
User ID:         501
 
Date/Time:       2013-11-22 14:15:44.585 +0100
OS Version:      Mac OS X 10.9 (13A603)
Report Version:  11
Anonymous UUID:  80CD43E4-D7C4-0963-3DFB-59E9F661443C
 
 
Crashed Thread:  0  Dispatch queue: com.apple.main-thread
 
Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
 
Dyld Error Message:
  Symbol not found: _OTSetNonBlocking
  Referenced from: /Applications/Wolfenstein ET/Wolfenstein ET.app/Contents/MacOS/Wolfenstein ET
  Expected in: /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
 
Can somebody help me?


#7
djbo

djbo
  • Gender:Male
  • Location:Belgium
  • Server:Bunker #2
Click to view battle stats

For now I can only refer to this topic

 

http://forums.warche...-10-9-Mavericks

 

Did a quick test myself and I could open ET, meaning it ran but first problem I noticed however was that I couldn't pull down the console so I kinda stopped there and didn't test any further yet.



#8
CrazyT

CrazyT

    Hi, My Name Is..

  • Bunker Members
  • 17 posts
  • Gender:Male
  • Location:Netherlands
  • Server:Unselected
Click to view battle stats

Thanks djbo for you quick reply!

I tried what they told on the forum but i still get the same error.

Do you play ET on wineskin?



#9
*CapTn*

*CapTn*

    Will Become Famous Soon Enough

  • Members
  • 1,929 posts
  • Steam:captn3
  • Gender:Male
  • Location:wheres your mom?
  • Server:Bunker #1
Click to view battle stats

this is interesting..

 

i can dig around too see if i can make work. let me know if you need futher help.



#10
peyote

peyote
  • Gender:Male
  • Location:Basel
  • Server:Bunker #2
Click to view battle stats

You have the same error as the guy who posted on Splashdamage, there is no fix for that.

 

What you can try is installing ET:Legacy done by Radegast, see this post:

http://forums.warche...ll=1#post479611

 

Else you can try wineskin, at least that is my recommendation. But I have no OSX 10.9 and I never tried that. I used Wineskin under OSX 10.6 for older games and it was excellent.



#11
djbo

djbo
  • Gender:Male
  • Location:Belgium
  • Server:Bunker #2
Click to view battle stats
I tried etl, also tried wineskin but that lagged like hell and poses the same keyboard problems. ETL has great potential tho, just needs to be streamlined and the keyboard problem (pulling down console etc... ) need to be addressed, or perhaps I did something wrong. Should have time early next week to do some more testing.

#12
CrazyT

CrazyT

    Hi, My Name Is..

  • Bunker Members
  • 17 posts
  • Gender:Male
  • Location:Netherlands
  • Server:Unselected
Click to view battle stats

Fixed it.

I found a backup on time-machine with parallels desktop on it and now I run it on microsoft

 

Thanks guys